Get the 1&1 Vagrant Plug-In

Table of Contents

Introduction

This is a Vagrant plugin that adds a 1&1 provider to Vagrant, which allows Vagrant to control and provision machines in the 1&1 Server Cloud.

Features

  • Create and destroy servers.
  • Start, stop and restart servers.
  • Provision the servers with built-in Vagrant provisioners.
  • SSH into the instances.
  • Custom sub-commands within the Vagrant CLI to query 1&1 Server entities.

Requirements

  • Ruby 2.0 or higher
  • Vagrant 1.4+
  • 1&1 API access key
  • SSH (RSA) public/private key pair

Note: Public and private keys need to be stored on the same location.

Install

Install the plugin using the standard installation method, the Vagrant command-line interface:

vagrant plugin install vagrant-oneandone

Comments

vagrant plugin install vagrant-oneandone results in (vagrant version: Installed Version: 1.9.5)
/opt/vagrant/embedded/lib/ruby/2.2.0/rubygems/specification.rb:2100:in `check_version_conflict': can't activate i18n-0.6.11, already activated i18n-0.8.0 (Gem::LoadError)

Hello rsz, thank you for your patience while we researched this issue. The problem has been resolved, and you should be able to use the Vagrant plugin without any problems now.

Hello rsz, thank you for your patience while we researched this issue. The problem has been resolved, and you should be able to use the Vagrant plugin without any problems now.

Tags: Vagrant