Get the 1&1 Chef Knife Plugin

Table of Contents

Description

1&1 Chef Knife plugin for managing 1&1 Cloud servers. To view or contribute to this project, visit the GitHub repository.

Requirements

  • Chef 12.3.0 or higher
  • Ruby 2.1.x or higher

Installation

Add this line to your application's Gemfile:

gem 'knife-oneandone'

And then execute:

bundle

Or install it yourself as:

gem install knife-oneandone

Configuration

The 1&a1 Chef Knife plugin requires a valid 1&1 API key. Add your 1&1 API key in a knife.rb configuration file (for example in ~/.chef/knife.rb).

knife[:oneandone_api_key] = '_YOUR_API_KEY_'

Comments

Tags: Chef